closed

Loginbox

Please enter your username and password into the following fields to log in.


  • Username:
  • Password:
  •  
  • Auto log in on every visit.


  •  

ISP-3 Driver "not migrated" after recent WIN10 64-bit update, help!



allan offline
Benutzer
Avatar
Gender: n/a
Location: n/a 
Age: 57
Posts: 10
Registered: 10 / 2016
Private message
Subject: Re: ISP-3 Driver "not migrated" after recent WIN10 64-bit update, help!  -  Posted: 21.09.2017 - 11:37   -  
Yes, I have the same driver version, but Win10.
With this driver I can start programmer(s) from IDE 'Prommer' button and everything works fine, can read back or program chips etc.
But an attempt to compile the source ends with "Error: ;Programmer not found"
So it is found and not found simultaneously, not unlike the schrödinger's cat :)

Is there any way to make the compiler work with this driver?
This post has been edited 1-times. Last edit: 21.09.2017 - 11:38 by allan.
go down go up
Gunter offline
Administrator
Avatar
Gender: male
Location: GERMANY  Frankfurt Main / Germany
Age:
Posts: 1524
Registered: 02 / 2003
Private message
Subject: Re: ISP-3 Driver "not migrated" after recent WIN10 64-bit update, help!  -  Posted: 21.09.2017 - 12:42   -  
Hi,
no, it's not like Schrödinger's cat, because there are 2 different cats (.exe) checking the programmer:
AVRco.exe AND AVRprog.exe. The programmer button starts AVRprog. The compile/make
starts the AVRco.exe.
The only difference to my Win10/64 is the compatibility mode of PED32.ece: I set it to "Win8".
IIRC "Win7" also worked - but unusually slow. But I use the newest AVRco.

Gunter
2 Dinge sind unendlich: das Universum und die menschliche Dummheit.
Aber bei dem Universum bin ich mir noch nicht ganz sicher
--
Albert Einstein
This post has been edited 3-times. Last edit: 21.09.2017 - 16:13 by Gunter.
go down go up
miparo offline
Schreiberling
Avatar
Gender: male
Location: GERMANY  Germany
Age:
Posts: 544
Registered: 09 / 2007
Private message
Subject: Re: ISP-3 Driver "not migrated" after recent WIN10 64-bit update, help!  -  Posted: 21.09.2017 - 23:41   -  
Hi Allan,
all AVRco versions < 5.09.00 need the old USB driver.
With your old AVRco version 5.02.x and new usb driver no chance.
Update AVRco $$ or install old usb driver.

miparo
Kein Support per PN! | No support via PM!
This post has been edited 1-times. Last edit: 21.09.2017 - 23:44 by miparo.
go down go up
 


Registered users in this topic
Currently no registered users in this section

Delete cookies of this forum  •  FAQ / Help  •  Team page  •  Imprint   |  Local time: 17.10.2017 - 09:48